User:Fab/Metasploit

From Alpine Linux
Jump to: navigation, search

depends

  • ruby-irb ruby-ri rubygems
  • subversion
  • ruby-dev libpcap-devel
  • postgresql postgresql-dev

testing if ruby-pg is working sudo gem install pg # you can't use the distro ruby-postgres rpm as a replacement

Installation

wget http://downloads.metasploit.com/data/releases/framework-latest.tar.bz2 tar -jxf framework-latest.tar.bz2 sudo mkdir -p /opt/metasploit4 sudo cp -a msf/ /opt/metasploit4/msf sudo chown root:root -R /opt/metasploit4/msf sudo ln -sf /opt/metasploit4/msf/msf* /usr/local/bin/