Release Notes for Alpine 3.11.0 (ideas)

From Alpine Linux
Jump to: navigation, search

List of possible release notes for 3.11.0

Notable Changes

Rust now on almost all arches

Rust >= 1.37.0-r0 is now enabled on all arches except s390x

Vulkan support

KDE Plasma and GNOME on community

KDE Plasma and GNOME are now on the community repository.

MinGW-w64 and DXVK support

The MinGW suite up to mingw-w64-gcc is packaged. The following MinGW packages are now available:

/var/mail now default MAIL location

Packages now all use /var/mail instead of /var/spool/mail, in accordance with FHS:

NOTE: Upgrading from 3.10 to 3.11 might require manual intervention in the form of moving /var/spool/mail to /var/mail if the system can't do it automatically.

  • alpine-baselayout >= 3.2.0-r0 now creates /var/mail and symlinks /var/spool/mail to it
  • tcsh >= 6.21.00-r0 now sets MAILDIR to /var/mail/$USER if it exists
  • mutt >= 1.12.1-r1 is now configured to use /var/mail instead of /var/spool/mail
  • heirloom-mailx >= 12.4-r7 now uses /var/mail
  • opensmtpd >= 6.0.3p1-r4 now uses /var/mail
  • s-nail >= 14.9.13-r2 now uses /var/mail

ulogd now has some output plugins split

Starting with ulogd-2.0.7-r3 plugins that depend on external libraries like 'json', 'sqlite3', 'mysql' and 'pgsql' are now split into its own subpackages named 'ulogd-$plugin'.

This is done to reduce the size of the package and its dependencies, for example, people that only use the 'syslog' and 'gprint' plugins don't need to bring the heavier 'json' and 'mysql' plugins and its dependencies on external libraries like 'libjansson'.

musl >= 1.1.24-r0 supports GLOB_TILDE and secure_getenv

musl now supports GLOB_TILDE and secure_getenv, all packages that had it disabled have been rebuilt.

Packages affected by GLOB_TILDE:

  • i3wm >= 4.17.1-r1
  • i3wm-gaps >= 4.17.1-r1
  • i3status >= 2.13-1
  • taskd >= 1.1.0-r6
  • policycoreutils >= 2.8-r1
  • ipsec-tools >= 0.8.2-r9

Packages affected by secure_getenv:

  • libuser >= 0.62-r3
  • networkmanager >= 1.20.4-r1
  • elogind >= 241.3-r3
  • chromium >= 77.0.3865.120-r1
  • gnutls >= 3.6.10-r0

xz is now compiled as an applet of busybox

xz (the binary) is now compiled as an applet of the busybox package, and will be installed as a symlink in /usr/bin/xz, the following packages dropped their dependency on the fully-featured but larger xz (the package) in favour of the busybox equivalent:

  • gettext >= 0.20.1-r2
  • distrobuilder >= 0_git20181004-r2
  • kexec-tools >= 2.0.20-r1
  • lxc >= 3.2.1-r2
  • lxd >= 3.18-r1
  • dpkg >= 1.19.7-r1
  • texlive >= 20190410-r6

NOTE: you can install the xz package to get the fully featured xz if necessary. It will take over the spot of busybox's xz in /usr/bin/xz

Changes in abuild

The following changes have been made in abuild:

Fix condition check for -dev subpackage to get static libraries

Before this fix abuild would include the static libraries in the -dev subpackage even when -static was defined in subpackages, causing the latter to fail.

Now the check is properly done.

default_static now depends on depends_static

default_static used to completely cancel out any dependencies but now it depends on all packages listed in the depends_static variable.

newapkbuild -y now depends on py3-setuptools instead of python3-dev

When using newapkbuild to make py3- packages the default definition now includes only py3-setuptools instead of python3-dev as the first one is used in almost all cases while python3-dev is used only when linking to the python3 library.

Better checking of SPDX compliance

Abuild now checks the /usr/share/spdx/license.lst more accurately, before the new check it would not match the whole line and wrong definitions like 'GPL-3.0' would match while the only valid ones in that case were 'GPL-3.0-or-later' and 'GPL-3.0-only'.