APKBUILD examples:Special Subpackages Doc
Sometimes there is a large amount of documentation files in the source available. If you want to ship these files in a -doc packages the snippet below can help you. Packaging only a license file and be done as described here.
Contents of php81/APKBUILD
...
doc() {
# Man pages
mkdir -p "$subpkgdir"/usr/share/man || return 1
mv "$pkgdir"/usr/share/man/man* "$subpkgdir"/usr/share/man/ \
|| return 1
# Doc files
_docs="CODING_STANDARDS CREDITS EXTENSIONS INSTALL LICENSE NEWS \
README.EXTENSIONS README.EXT_SKEL README.MAILINGLIST_RULES \
TODO-PHP5 UPGRADING UPGRADING.INTERNALS"
for _doc in $_docs; do
install -Dm644 "$srcdir"/$pkgname-$pkgver/$_doc \
"$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
done
}
...
Source: PHP APKBUILD