Difference between revisions of "Upgrading from older versions"

From Alpine Linux
Jump to: navigation, search
(tweaks, formatting)
(Prune to only pre-2.2 instructions)
Line 1: Line 1:
{{Note|You will need to restart any services that have been upgraded to begin using the upgraded versions. If the kernel is upgraded, you will need to reboot to begin using the upgraded version.}}
 
 
== Upgrading from 2.1 to Alpine Linux 2.2 and later ==
 
Since '''apk''' tool has been significantly changed first make sure you have upgraded ''apk-tools'' package to latest version available in 2.1 repositories:
 
 
{{Cmd|apk update --update-cache
 
apk add --upgrade apk-tools}}
 
 
Change repositories:
 
{{Cat|/etc/apk/repositories|...
 
http://nl.alpinelinux.org/alpine/v2.2/main
 
# or any other mirror
 
}}
 
 
Proceed with update and upgrade. The <code>--available</code> switch is used to force all packages to be upgraded, even if they have the same version number, due to changes in uClibc:
 
{{Cmd|apk update --update-cache
 
apk upgrade --available --update-cache}}
 
 
Reboot the system to load new kernel
 
{{Cmd|sync
 
reboot}}
 
 
 
 
== Upgrading from 2.0 or 1.10.x to Alpine Linux 2.2 and later ==
 
== Upgrading from 2.0 or 1.10.x to Alpine Linux 2.2 and later ==
Since '''apk''' tool has been significantly changed you need to download and install manually the latest version of ''apk-tools-static'' package.<BR>
+
Since the '''apk''' tool has been significantly changed you need to download and install manually the latest version of {{Pkg|apk-tools-static}}. We also install {{Pkg|busybox-static}} just in case something goes wrong.
And we install ''busybox-static'' just in case something goes wrong.
 
  
 
If current version is 1.10.x remove GNU Wget before attempting an upgrade:
 
If current version is 1.10.x remove GNU Wget before attempting an upgrade:
 
{{Cmd|apk del wget}}
 
{{Cmd|apk del wget}}
  
 
+
Download {{Pkg|busybox-static}} and install it:
Download busybox-static package and install it:
 
 
{{Cmd|wget http://nl.alpinelinux.org/alpine/v2.2/main/x86/busybox-static-1.18.4-r3.apk
 
{{Cmd|wget http://nl.alpinelinux.org/alpine/v2.2/main/x86/busybox-static-1.18.4-r3.apk
 
apk add busybox-static-1.18.4-r3.apk --update-cache}}
 
apk add busybox-static-1.18.4-r3.apk --update-cache}}
  
Download apk-tools-static package and install it:
+
Download {{Pkg|apk-tools-static}} and install it:
 
{{Cmd|wget http://nl.alpinelinux.org/alpine/v2.2/main/x86/apk-tools-static-2.1.0-r1.apk
 
{{Cmd|wget http://nl.alpinelinux.org/alpine/v2.2/main/x86/apk-tools-static-2.1.0-r1.apk
 
apk add apk-tools-static-2.1.0-r1.apk --update-cache}}
 
apk add apk-tools-static-2.1.0-r1.apk --update-cache}}
Line 46: Line 21:
 
Proceed with update and upgrade. The <code>--available</code> switch is used to force all packages to be upgraded, even if they have the same version number, due to changes in uClibc:
 
Proceed with update and upgrade. The <code>--available</code> switch is used to force all packages to be upgraded, even if they have the same version number, due to changes in uClibc:
 
{{Cmd|apk.static update --update-cache
 
{{Cmd|apk.static update --update-cache
apk.static upgrade --available --update-cache}}
+
apk.static upgrade --update-cache --available}}
  
 
Reboot the system to load new kernel
 
Reboot the system to load new kernel
 
{{Cmd|sync
 
{{Cmd|sync
 
reboot}}
 
reboot}}
 
  
 
[[Category:Installation]]
 
[[Category:Installation]]
 
[[Category:Package Manager]]
 
[[Category:Package Manager]]

Revision as of 16:46, 29 October 2012

Upgrading from 2.0 or 1.10.x to Alpine Linux 2.2 and later

Since the apk tool has been significantly changed you need to download and install manually the latest version of apk-tools-static. We also install busybox-static just in case something goes wrong.

If current version is 1.10.x remove GNU Wget before attempting an upgrade:

apk del wget

Download busybox-static and install it:

wget http://nl.alpinelinux.org/alpine/v2.2/main/x86/busybox-static-1.18.4-r3.apk apk add busybox-static-1.18.4-r3.apk --update-cache

Download apk-tools-static and install it:

wget http://nl.alpinelinux.org/alpine/v2.2/main/x86/apk-tools-static-2.1.0-r1.apk apk add apk-tools-static-2.1.0-r1.apk --update-cache

Change repositories:

Contents of /etc/apk/repositories

... http://nl.alpinelinux.org/alpine/v2.2/main # or any other mirror

Proceed with update and upgrade. The --available switch is used to force all packages to be upgraded, even if they have the same version number, due to changes in uClibc:

apk.static update --update-cache apk.static upgrade --update-cache --available

Reboot the system to load new kernel

sync reboot