Main Page/Adding sound

From Alpine Linux
Jump to: navigation, search
Underconstruction clock icon gray.svg
This material is work-in-progress ...

Do not follow instructions here until this notice is removed.
(Last edited by Innsill on 14 Sep 2019.)

First you will need to install Alsa packages, the Linux sound driver and volume adjuster.

# apk add alsa-utils alsa-utils-doc alsa-lib alsa-conf

Then you will need to add all your users (including root) to /etc/group.

# nano /etc/group

Scroll down until you find the line that starts with "audio:x:18:" and add all the users, for example if the name of root is "root" and a user is "user", separated by commas.

audio:x:18:root,user

Save your nano work by pressing Ctrl+O and confirm the changes by pressing enter. Then exit nano by pressing Ctrl+X.

Find the default sound card.

# alsamixer

The default sound card will show up. Try turning up the volume of Master and the device(s) such as speakers or microphones that you need, and audio should work.

If there are no volume controls visible, try hitting F6 on your keyboard and toggling between the sound cards (which all might have the same name in the context menu that pops up except for the numbers next to and before the names).

Once you've found the sound card name that gives you volume controls, set the unique number that showed up in the F6 context menu as your default soundcard.

# nano /usr/share/alsa/alsa.conf

Scroll down until you find the lines that start with "defaults.ctl.card" and "defaults.pcm.card" and put the number (you found in the F6 context menu of the alsamixer command for the soundcard you want as your default) at the end of those lines separated by a space for each. For example, if the default sound card you want is "1".

defaults.ctl.card 1

defaults.pcm.card 1

Save your nano work by pressing Ctrl+O and confirm the changes by pressing enter. Then exit nano by pressing Ctrl+X.

Try turning up the volume of Master and the device(s) such as speakers or microphones that you need with the alsamixer command, and audio should work.

Help needed: how to make the default sound card and device show up in the Audio Mixer GUI in the XFCE menu and taskbar, so that you can use a GUI instead of the alsamixer command in the terminal?