Difference between revisions of "Talk:Python package policies"

From Alpine Linux
Jump to: navigation, search
(Created page with "This page duplicates quite a bit of details which are already present: - https://wiki.alpinelinux.org/wiki/Package_policies - https://wiki.alpinelinux.org/wiki/APKBUILD_examp...")
 
(Add _pyname pro)
 
(4 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
This page duplicates quite a bit of details which are already present:
 
This page duplicates quite a bit of details which are already present:
  
- https://wiki.alpinelinux.org/wiki/Package_policies
+
* https://wiki.alpinelinux.org/wiki/Package_policies
- https://wiki.alpinelinux.org/wiki/APKBUILD_examples:Python
+
* https://wiki.alpinelinux.org/wiki/APKBUILD_examples:Python
  
 
Instead of creating a new page the existing information should be updated.
 
Instead of creating a new page the existing information should be updated.
 +
 +
----
 +
 +
`_py2_depends` and `_py3_depends` are more consistent with the other variable names and preferable to '_py2_deps' and '_py3_deps' in my opinion.
 +
 +
Agreed, but I've removed all of the Python 2 details entirely pending the coming EoL.
 +
--[[User:Ddevault|Ddevault]] ([[User talk:Ddevault|talk]]) 15:10, 24 January 2020 (UTC)
 +
 +
 +
----
 +
 +
_pyname is much less common than _pkgname although _pkgname is used for many things; would be good to have a clear recommended name
 +
 +
_pyname was per ncopa's suggestion, I don't have a problem with it.
 +
--[[User:Ddevault|Ddevault]] ([[User talk:Ddevault|talk]]) 15:10, 24 January 2020 (UTC)
 +
 +
my only issue with _pyname is that it is less common; I agree _pkgname is more common and longer term consistency would be good, we had a discussion about it today on IRC; the consensus there is that it is a private variable and the name doesn't matter. --[[User:Keith.maxwell|Keith.maxwell]] ([[User talk:Keith.maxwell|talk]]) 09:25, 12 April 2020 (UTC)
 +
 +
a good argument for _pyname from IRC is that "More descriptive  names are preferable, _pkgname doesn't really tell much" [[User:Keith.maxwell|Keith.maxwell]] ([[User talk:Keith.maxwell|talk]]) 09:38, 12 April 2020 (UTC)

Latest revision as of 09:39, 12 April 2020

This page duplicates quite a bit of details which are already present:

Instead of creating a new page the existing information should be updated.


`_py2_depends` and `_py3_depends` are more consistent with the other variable names and preferable to '_py2_deps' and '_py3_deps' in my opinion.

Agreed, but I've removed all of the Python 2 details entirely pending the coming EoL. --Ddevault (talk) 15:10, 24 January 2020 (UTC)



_pyname is much less common than _pkgname although _pkgname is used for many things; would be good to have a clear recommended name

_pyname was per ncopa's suggestion, I don't have a problem with it. --Ddevault (talk) 15:10, 24 January 2020 (UTC)

my only issue with _pyname is that it is less common; I agree _pkgname is more common and longer term consistency would be good, we had a discussion about it today on IRC; the consensus there is that it is a private variable and the name doesn't matter. --Keith.maxwell (talk) 09:25, 12 April 2020 (UTC)

a good argument for _pyname from IRC is that "More descriptive names are preferable, _pkgname doesn't really tell much" Keith.maxwell (talk) 09:38, 12 April 2020 (UTC)