Difference between revisions of "Redmine"

From Alpine Linux
Jump to: navigation, search
(Initial draft)
 
m (Updated now that ruby is working properly)
Line 1: Line 1:
 
{{Draft}}
 
{{Draft}}
apk add rubygems mysql mysql-dev<br />
+
apk add lighttpd fcgi rubygems mysql mysql-dev<br />
 
gem install rack -v=1.0.1<br />
 
gem install rack -v=1.0.1<br />
 
gem install rails -v=2.3.5<br />
 
gem install rails -v=2.3.5<br />
Line 15: Line 15:
 
rake generate_session_store<br />
 
rake generate_session_store<br />
 
RAILS_ENV=production rake db:migrate<br />
 
RAILS_ENV=production rake db:migrate<br />
RAILS_ENV=production rake redmine:load_default_data<br />
+
RAILS_ENV=production rake redmine:load_default_data (keep default language of en)<br />
  Receiving error here:
+
  ruby script/server webrick -e production
/usr/bin/ruby: symbol 'each_conf_value_doall_arg': can't resolve symbol in lib '/usr/lib/ruby/1.8/i486-linux-uclibc/openssl.so'.
+
localhost:3000
rake aborted!
+
user admin:admin
give redmine user write permissions to files,log,tmp<br />
+
Edit lighttpd.conf and uncomment "include mod_fastcgi.conf"<br />
ruby script/server webrick -e production<br />
+
Restart lighttpd. <br />
localhost:3000<br />
 
user admin:admin<br />
 
 
 
Possible solution to ruby error is to upgrade to Ruby 1.8.7-p299
 

Revision as of 20:23, 15 November 2010

Underconstruction clock icon gray.svg
This material is work-in-progress ...

Do not follow instructions here until this notice is removed.
(Last edited by Jbilyk on 15 Nov 2010.)

apk add lighttpd fcgi rubygems mysql mysql-dev
gem install rack -v=1.0.1
gem install rails -v=2.3.5
gem install mysql
mysql commands:

create database redmine character set utf8;
grant all privileges on redmine.* to 'redmine'@'localhost' identified by 'Secur3P@ass';
flush privileges;

mkdir /usr/share/webapps/redmine
copy over redmine-1.0.3.tar.gz contents into folder
chown -R lighttpd:lighttpd /usr/share/webapps/redmine
edit config/database.yml (copied from database.yml.example) production section to match above mysql settings
cd /usr/share/webapps/redmine
rake generate_session_store
RAILS_ENV=production rake db:migrate
RAILS_ENV=production rake redmine:load_default_data (keep default language of en)

ruby script/server webrick -e production
localhost:3000
user admin:admin

Edit lighttpd.conf and uncomment "include mod_fastcgi.conf"
Restart lighttpd.